»查看更多分類股票軟件

金磚主圖 強勢選股 大智慧指標 源碼 貼圖

發布時間:2018-11-20 10:07:00  點擊:

 {四價數據}
n:=30;m:=95;

C1:REF(C,1),linethick0;
L1:REF(L,1),linethick0;
{引用 自定義}
買入日期:=selfstring('買入日期');
買入價:=SELFDATA('買入價');
{以下設置個股信息}
DRAWTEXTREL(5,950,'■今天日期: '+YEAR+'年 '+MONTH+'月 '+DAY+'日 '),linethick2,Colormagenta,layer0;
WW:=BARSLAST(DISPSTATUS=1);
天:=BARSLAST(L=LLV(LOW,WW));
DRAWTEXTREL(5,915,'■目前可見K線:'+NUMTOSTRN(WW+1,0)+'天 50~65天看短中波段'),linethick1,COLOR00ff00,layer0;
{MACD優化----大智慧L2版本}
DIFF:= EMA(CLOSE,12) - EMA(CLOSE,26);
DEA := EMA(DIFF,9);
MACD:= 2*(DIFF-DEA);
主升:= DIFF>0 AND DIFF>DEA;
結束:=CROSS(DEA,DIFF);
強度:=DIFF-DEA;
強度1:=ref(強度,1);
{FILLRGN(DIFF,DEA,主升,RGB(250,0,0));}
轉弱:=DIFF>0 AND 強度<強度1;
ZSQD1:=主升=1 AND 強度>強度1;{強上}
ZSQD2:=主升=1 AND 強度<強度1;{轉弱}
ZSQD3:=主升<=O AND DIFF>DEA;
ZSQD4:=主升<=O AND DIFF<DEA;
IF BARSTATUS=2 AND ZSQD1 THEN BEGIN
DRAWTEXTREL(400,120 ,'● MACD 0線上 上升中 持股!'),COLOR0000FF,LINETHICK2,LAYER0;
END
ELSE
IF BARSTATUS=2 AND ZSQD2 THEN BEGIN
DRAWTEXTREL(400,120 ,'● MACD 0線上 下降中 小心!'),COLOR00FFFF,LINETHICK2,LAYER0;
END
ELSE
IF BARSTATUS=2 AND ZSQD3 THEN BEGIN
DRAWTEXTREL(400,120 ,'● MACD 0線下 上升中 觀望!'),COLORFFFFFF,LINETHICK2,LAYER0;
END
ELSE
IF BARSTATUS=2 AND ZSQD4 THEN BEGIN
DRAWTEXTREL(400,120 ,'● MACD 0線下 下降中 放棄!'),COLOR00FF00,LINETHICK2,LAYER0;
END
{回調買入}
{HH:=HHV(HIGH,10);
LL:=LLV(LOW,30);
回調:=(HH+LL)/2;
DRAWTEXTREL(5,770,'■ 十天最高價:'+NUMTOSTRN(HH,2)+'元'),COLOR00ffff,LINETHICK1;
DRAWTEXTREL(5,810,'■ 三十天最低價:'+NUMTOSTRN(LL,2)+'元'),COLOR00ffff,LINETHICK1;
DRAWTEXTREL(5,850,'■ 回調買入價:'+NUMTOSTRN(回調,2)+'元 收盤價:'+NUMTOSTRN(C,2)+'元'),COLOR00ffff,LINETHICK1;}

DRAWTEXTREL(250,20,' 趨勢分析'),COLORFFFFFF,layer0,LINETHICK2;

{3 8 21 均線}
MA3:=MA(CLOSE,3);
MA8:=MA(CLOSE,8);
MA21:=MA(CLOSE,21);
三線紅:=MA3>REF(MA3,1) AND MA8>REF(MA8,1) AND MA21>REF(MA21,1);
三線上:=MA3>MA8 AND MA8>MA21
AND MA3>REF(MA3,1) AND MA8>REF(MA8,1) AND MA21>REF(MA21,1) ;
回調線:=MA3<REF(MA3,1) AND MA8>REF(MA8,1) AND MA21>REF(MA21,1) ;
趨勢:=MA21/REF(MA21,1);
趨勢1:=趨勢>=1.003;
趨勢2:=趨勢<1.003;
趨勢3:=趨勢<0;
IF BARSTATUS=2 AND 趨勢1 THEN BEGIN
DRAWTEXTREL(240,120 ,'● 均線趨勢 走強 持股!'),COLOR0000FF,LINETHICK2;
END
ELSE
IF BARSTATUS=2 AND 趨勢2 THEN BEGIN
DRAWTEXTREL(240,120 ,'● 均線趨勢 走平 小心!'),COLOR00FFFF,LINETHICK2;
END
ELSE
IF BARSTATUS=2 AND 趨勢3 THEN BEGIN
DRAWTEXTREL(240,120 ,'● 均線趨勢 走弱 退場!'),COLOR00FF00,LINETHICK2;
END
{DRAWTEXT(MA21,MA21,'●'),COLORGREEN,linethick1,align1 ;}
{DRAWTEXT(MA21>ref(ma21,1),MA21,'◎'),COLOR00FF00,linethick1,align1 ;}
天數21:=barslast(CROSS(MA21,ref(ma21,1)));{計算上漲天數};

{新牛股公式}
牛股:=100-100*(HHV(HIGH,5*8)-CLOSE)/(HHV(HIGH,5*8)-LLV(LOW,5*8));
牛現:CROSS((100-100*(HHV(HIGH,5*8)-CLOSE)/(HHV(HIGH,5*8)-LLV(LOW,5*8))),99),linethick0;
kk:=-150;
kkk:=790;
NG1:=牛股>REF(牛股,1);
NG2:=牛股<REF(牛股,1);
NG3:=牛股=REF(牛股,1);
IF BARSTATUS=2 AND NG1 THEN BEGIN
DRAWRECTREL(380+kk,50+kkk,520+kk,220+kkk,rgb(0,0,255)),layer0,colorffffff,LINETHICK1;
DRAWTEXTREL(382+kk,70+kkk,' 【股價 上升】'),COLORRED,linethick3,layer0;
DRAWTEXTREL(382+kk,120+kkk,' 今日趨勢: '+NUMTOSTRN(牛股,2)),COLORRED,linethick2,layer0;
DRAWTEXTREL(382+kk,170+kkk,' 昨日趨勢: '+NUMTOSTRN((REF(牛股,1)),2)),COLORGREEN,linethick2,layer0;
DRAWTEXTREL(870,940,'金磚強勢選股'),COLOR0000FF,linethick4,layer0;
END
ELSE
IF BARSTATUS=2 AND NG2 THEN BEGIN
DRAWRECTREL(380+kk,50+kkk,520+kk,220+kkk,rgb(47,79,79)),layer0,color00FF00,LINETHICK1;
DRAWTEXTREL(382+kk,70+kkk,' 【股價 下跌】'),COLORFFFFFF,linethick2,layer0;
DRAWTEXTREL(382+kk,120+kkk,' 今日趨勢: '+NUMTOSTRN(牛股,2)),COLORFFFFFF,linethick2,layer0;
DRAWTEXTREL(382+kk,170+kkk,' 昨日趨勢: '+NUMTOSTRN((REF(牛股,1)),2)),COLORRED,linethick2,layer0;
DRAWTEXTREL(870,940,'金磚強勢選股'),COLOR00FF00,linethick4,layer0;
END
ELSE
IF BARSTATUS=2 AND NG3 THEN BEGIN
DRAWRECTREL(380+kk,50+kkk,520+kk,220+kkk,rgb(0,0,255)),layer0,colorFFFFFF,LINETHICK1;
DRAWTEXTREL(382+kk,70+kkk,' 【股價 平盤】'),COLORYELLOW,linethick3,layer0;
DRAWTEXTREL(382+kk,120+kkk,' 今日趨勢: '+NUMTOSTRN(牛股,2)),COLORYELLOW,linethick2,layer0;
DRAWTEXTREL(382+kk,170+kkk,' 昨日趨勢: '+NUMTOSTRN((REF(牛股,1)),2)),COLORFFFFFF,linethick2,layer0;
DRAWTEXTREL(870,940,'金磚強勢選股'),COLORFFFFFF,linethick4,layer0;
END
NX:=牛現>0;
IF BARSTATUS=2 AND NX THEN BEGIN
DRAWRECTREL(380+kk,50+kkk,520+kk,220+kkk,rgb(0,0,255)),layer0,colorffffff,LINETHICK1;
DRAWRECTREL(398+kk,84+kkk,482+kk,183+kkk,rgb(255,0,0)),layer0,colorffffff,LINETHICK1;
DRAWTEXTREL(406+kk,110+kkk,'牛 股'),COLORFFFFFF,linethick5,layer0;
DRAWTEXTREL(870,940,'金磚強勢選股'),COLOR0000FF,linethick4,layer0;
END
{買入表格}
DRAWTEXTREL(177,20,'昨今趨勢'),COLORFFFFFF,layer0,LINETHICK2;
{顯示金磚 藍磚 DPPD提供薛絲通道公式}
XSVAR2:=CLOSE*VOL;
XSVAR3:=EMA((EMA(XSVAR2,3)/EMA(VOL,3)+EMA(XSVAR2,6)/EMA(VOL,6)+EMA(XSVAR2,12)/EMA(VOL,12)+EMA(XSVAR2,24)/EMA(VOL,24))/4,13);
XSVAR4:=EMA(CLOSE,9);
SUP:1.06*XSVAR3,linethick0;{強勢上升}
SUP1:=REF(SUP,1);
SUP2:=REF(SUP,2);
HUP:EMA(XSVAR4*1.14,5),linethick0;{頂部高位}
{DRAWTEXT(HUP>ref(HUP,1),HUP,'◎'),COLORmagenta,linethick1,align1 ;}
金磚:=SUP>SUP1 AND C>SUP;
藍磚:=SUP>SUP1 AND C<SUP;
IF BARSTATUS=2 AND 金磚 THEN BEGIN
DRAWTEXTREL(205,70,'■'),COLOR00FFFF,layer0,LINETHICK3;
END
ELSE
IF BARSTATUS=2 AND 藍磚 THEN BEGIN
DRAWTEXTREL(205,70,'■'),COLOR00ff00,layer0,LINETHICK3;
END
金磚1:=SUP1>SUP2 AND C1>SUP1;
藍磚1:=SUP1>SUP2 AND C1<SUP1;
IF BARSTATUS=2 AND 金磚1 THEN BEGIN
DRAWTEXTREL(177,70,' ■'),COLOR00FFFF,layer0,LINETHICK3;
END
ELSE
IF BARSTATUS=2 AND 藍磚1 THEN BEGIN
DRAWTEXTREL(177,70,' ■'),COLOR00ff00,layer0,LINETHICK3;
END
STICKLINE(金磚,SUP,SUP1,6,0),CoLor00FFFF,LAYER0;{顯示金磚}
STICKLINE(藍磚,SUP,SUP1,6,0),CoLor00ff00,LAYER0;{顯示藍磚}
{顯示磚量}
磚量:=(SUP-SUP1)-(SUP1-SUP2);
FDU1:=磚量>0;
FDU2:=磚量<0;
IF BARSTATUS=2 AND FDU1 THEN BEGIN
DRAWTEXTREL(240,70 ,'● 磚量 增大 持股!'),COLORRED,LINETHICK2;
END
ELSE
IF BARSTATUS=2 AND FDU2 THEN BEGIN
DRAWTEXTREL(240,70 ,'▼ 磚量 縮小 小心!'),COLOR00FFFF,LINETHICK2;
END

{顯示紅磚 起漲}
JZVAR1:=(CLOSE+HIGH+LOW)/(3);
JZVAR2:=EMA(JZVAR1,10);
紅磚:=JZVAR2>REF(JZVAR2,1);
紅磚1:=REF(JZVAR2,1)>REF(JZVAR2,2);
STICKLINE(紅磚,JZVAR2,REF(JZVAR2,1),4,0),CoLorred,layer0;{顯示紅磚}
起漲1:=紅磚>0;
IF BARSTATUS=2 AND 起漲1 THEN BEGIN
DRAWTEXTREL(205,110,'■'),COLORRED,layer0,LINETHICK3;
END
起漲2:=紅磚1>0;
IF BARSTATUS=2 AND 起漲2 THEN BEGIN
DRAWTEXTREL(177,110,' ■'),COLORRED,layer0,LINETHICK3;
END
{強勢股買入信號}
強買:=金磚>0{超級買入}
AND 三線上;
{ AND 天數<=6;}
VERTLINE(CROSS(強買,0.1),2),COLORmagenta,layer2;
DRAWTEXT(CROSS(強買,0.1),C,'----'+NUMTOSTRN(C,2)),Colormagenta,linethick2,layer0;
DRAWTEXT(CROSS(強買,0.1),H*1.03,'☆強買'),Colormagenta,linethick1,ALIGN1,layer0;
起漲A:=藍磚>0 AND 紅磚>0 AND MA21>REF(MA21,1) {起漲買入}
AND 天數21<=3;
{AND 三線紅
AND (主升>0 OR REF(主升,1)>0) AND REF(DIFF,1)<0;
{AND SUP1<SUP2; }
VERTLINE(CROSS(起漲A,0.1),2),COLORFFFFFF,layer2;
DRAWTEXT(CROSS(起漲A,0.1),C,'----'+NUMTOSTRN(C,2)),ColorFFFFFF,linethick2,layer0;
DRAWTEXT(CROSS(起漲A,0.1),L*0.97,'☆起漲A'),ColorFFFFFF,linethick1,ALIGN1,layer0;

起漲B:=C1<SUP1 AND 藍磚>0 AND 紅磚>0 {起漲買入}
{AND 三線紅}
AND (主升>0 OR REF(主升,1)>0) AND REF(DIFF,1)<0;
{AND SUP1<SUP2; }
VERTLINE(CROSS(起漲B,0.1),2),COLOR00FFFF,layer2;
DRAWTEXT(CROSS(起漲B,0.1),C,'----'+NUMTOSTRN(C,2)),Color00FFFF,linethick2,layer0;
DRAWTEXT(CROSS(起漲B,0.1),L*0.98,'☆起漲B'),Color00FFFF,linethick1,ALIGN1,layer0;
{強勢股買入信號}
MR1:=(C1<SUP1 AND 金磚>0 AND 紅磚>0 AND 三線上>0)
OR (藍磚1>0 AND 金磚>0 AND 紅磚>0 AND 三線上>0)
OR (金磚>0 AND 三線上);{強買信號}
MR2:=(C1<SUP1 AND 藍磚>0 AND 紅磚>0 AND 三線紅>0 )
OR (藍磚>0 AND 紅磚>0 AND MA21>REF(MA21,1) AND REF(MA21,1)<REF(MA21,2))
OR (C1<SUP1 AND 藍磚>0 AND 紅磚>0);{起漲信號}
MR3:=金磚1>0 AND 金磚>0 AND 紅磚>0 AND 三線上>0;
MR4:=藍磚1>0 AND 藍磚>0 AND 紅磚>0 AND 三線上>0;
MR5:=(藍磚1>0 AND 藍磚>0 AND 紅磚>0 AND 三線紅>0) OR (金磚1>0 AND 藍磚>0 AND 紅磚>0 AND 三線紅>0);
MR6:=回調線>0 AND 紅磚>0;
MR7:=JZVAR2<REF(JZVAR2,1) OR 紅磚=0 OR (金磚=0 AND 藍磚=0);
IF BARSTATUS=2 AND MR1 THEN BEGIN
DRAWTEXTREL(600,50,'● 金磚出現 上漲行情 強買信號 MR1!'),COLORmagenta,LINETHICK4;
END
ELSE
IF BARSTATUS=2 AND MR2 THEN BEGIN
DRAWTEXTREL(600,50,'● 趨勢轉強 上升行情 起漲信號 MR2!'),COLOR00FFFF,LINETHICK4;
END
ELSE
IF BARSTATUS=2 AND MR3 THEN BEGIN
DRAWTEXTREL(600,50,'● 金磚出現 持續上漲行情 持股 MR3!'),COLOR0000FF,LINETHICK4;
END
ELSE
IF BARSTATUS=2 AND MR4 THEN BEGIN
DRAWTEXTREL(600,50,'● 趨勢強 持續上升行情 MR4!'),COLORmagenta,LINETHICK4;
END
ELSE
IF BARSTATUS=2 AND MR5 THEN BEGIN
DRAWTEXTREL(600,50,'● 趨勢平 持續上升行情 MR5!'),COLOR00FFFF,LINETHICK4;
END
ELSE
IF BARSTATUS=2 AND MR6 THEN BEGIN
DRAWTEXTREL(600,50,'● 金磚出現 回調行情 MR6!'),COLOR00CCFF,LINETHICK4;
END
ELSE
IF BARSTATUS=2 AND MR7 THEN BEGIN
DRAWTEXTREL(600,50,'▼ 金磚消失 看看就好!'),COLOR00FF00,LINETHICK4;
END
MR9:=金磚1>0 AND 金磚>0 AND JZVAR2>REF(JZVAR2,1)
AND C>HUP AND C1>REF(HUP,1)
AND C/REF(C,1)>1.05
AND REF(C,1)/REF(C,2)>1.05;
MR10:=金磚1>0 AND 金磚>0 AND JZVAR2>REF(JZVAR2,1)
AND C>HUP AND C1>REF(HUP,1)
AND C/REF(C,1)>1.05
AND REF(C,1)/REF(C,2)<1.05;
IF BARSTATUS=2 AND MR9 THEN BEGIN
DRAWTEXTREL(600,170,' ● 牛股 買入不后悔'),COLORRED,layer0,LINETHICK2;
END
ELSE
IF BARSTATUS=2 AND MR10 THEN BEGIN
DRAWTEXTREL(600,170,' ● 牛勢 買入不后悔'),COLOR00FFFF,layer0,LINETHICK2;
END

{趨勢分析}
AAA:=(3*C+H+L+O)/6;
VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;
VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3;
VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3;
VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
BBB:=VAR1>VAR6 AND REF(VAR1,1)=REF(VAR6,1);
CCC:=VAR1>VAR6 AND VAR6>VAR4 AND REF(VAR1,1)=REF(VAR4,1);
DDD:=VAR1=VAR4 AND VAR4>REF(VAR4,1);
EEE:=VAR1>VAR6 AND VAR1>REF(VAR1,1) AND VAR6>REF(VAR6,1);
FFF:=REF(VAR1,1)=REF(VAR4,1) AND VAR4>VAR1;
GGG:=VAR1=VAR6 AND VAR6<REF(VAR6,1);
HHH:=VAR1<REF(VAR1,1) AND VAR5>VAR1;
III:=(VAR1=VAR6) OR (VAR6=VAR4);
IF BARSTATUS=2 AND BBB THEN BEGIN
DRAWTEXTREL(400,70,'● 調整結束短線介入'),COLOR00FFFF,LINETHICK2;
END
ELSE
IF BARSTATUS=2 AND CCC THEN BEGIN
DRAWTEXTREL(400,70,'● 底部特征建倉時機'),COLOR00FFFF,LINETHICK2;
END
ELSE
IF BARSTATUS=2 AND (DDD OR EEE) THEN BEGIN
DRAWTEXTREL(400,70,'● 上升通道走勢良好'),COLOR0000FF,LINETHICK2;
END
ELSE
IF BARSTATUS=2 AND FFF THEN BEGIN
DRAWTEXTREL(400,70,'▼ 頂部特征注意風險'),COLOR00FF00,LINETHICK2;
END
ELSE
IF BARSTATUS=2 AND (GGG OR HHH OR III) THEN BEGIN
DRAWTEXTREL(400,70,'▼ 下跌通道回避觀望'),COLOR00FF00,LINETHICK2;
END
jjj:=ma8/ref(ma8,1)>1.022;
IF BARSTATUS=2 AND jjj THEN BEGIN
DRAWRECTREL(870,920,1000,1000,rgb(0,0,255)),layer0,colorffffff,LINETHICK1;
DRAWTEXTREL(880,935,'●大膽買入!'),COLOR0000ff,LINETHICK4,layer0;
END
{天河飲馬老師的成交量分析}
TT1:=V>REF(V,1) AND MA(V,5)>REF(MA(V,5),1);
TT2:=V<REF(V,1) AND MA(V,5)>REF(MA(V,5),1);
TT3:=V>REF(V,1) AND MA(V,5)<REF(MA(V,5),1);
TT4:=V<REF(V,1) AND MA(V,5)<REF(MA(V,5),1);
IF BARSTATUS=2 AND TT1 THEN BEGIN
DRAWTEXTREL(600,120 ,' ● 今日成交量大于昨日,且有繼續增大趨勢'),COLOR0000FF,LINETHICK2;
END
ELSE
IF BARSTATUS=2 AND TT2 THEN BEGIN
DRAWTEXTREL(600,120 ,' ● 今日成交量小于昨日,但有放大跡象'),COLORFFFFFF,LINETHICK2;
END
ELSE
IF BARSTATUS=2 AND TT3 THEN BEGIN
DRAWTEXTREL(600,120 ,' ● 今日成交量大于昨日, 但有縮小跡象'),COLOR00FFFF,LINETHICK2;
END
ELSE
IF BARSTATUS=2 AND TT4 THEN BEGIN
DRAWTEXTREL(600,120 ,' ● 今日成交量小于昨日,且有縮小跡象'),COLOR00FF00,LINETHICK2;
END;

金磚主圖 強勢選股 大智慧指標 源碼 貼圖

金磚主圖 強勢選股 大智慧指標 源碼 貼圖點擊下載金磚主圖 強勢選股 大智慧指標 源碼 貼圖

金磚主圖 強勢選股 大智慧指標 源碼 貼圖
打開微信掃一掃,一鍵復制指標源碼,
輕松快捷粘貼至手機通達信APP中。
0

本站提示:股市有風險,入市請慎重,資料由股票下載網整理收集

找不到你要的公式?給我們建議

  1. 股票軟件
    股票分析軟件
    股票交易軟件
    股票行情軟件
    指標股票池
    手機炒股軟件
    書籍教程
    數據軟件
    工具補丁
    大智慧
    通達信
    飛狐
    東方財富通
    操盤手
    指南針
    分析家
    同花順
    錢龍
    證券之星
    券商股票軟件
    特色行情軟件
    迷你行情軟件
    金融界軟件
    美股外盤軟件
    大智慧股票池
    通達信股票池
    大智慧L2公式
    通達信公式
    飛狐公式
    同花順公式
    股票書藉
    視頻教程
    金融書籍
    其他書籍
    資訊評測軟件
    資金分析軟件
    數據接口軟件
    江恩波浪軟件
    數據下載軟件
    軟件數據投資
    選股軟件
    登錄補丁
    其他應用
    股軟教程
  2. 股票公式
    通達信公式
    大智慧公式
    飛狐公式
    同花順公式
    東方財富通公式
    金字塔指標公式
    文華指標公式
    MT4指標
    博易大師指標
    公式教程答疑
  3. 炒股知識
    短線技巧
    軟件公式
    炒股視頻
    股票入門
    股市實戰信息交流
    炒股技巧
    股票基礎知識
    技術分析
    炒股一招先
    基本面分析
    股票視頻教程
    股票買賣技巧
    k線圖分析
    胡立陽教你買股票
    短線炒股技巧
    天狼之眼
    波浪理論技術講解
    股市贏家楊百萬
    股票理論、T0纏論、知識
    經典指標、交易系統
    成交量能、籌碼分析
    買賣信號、技術分析
    挖坑、冼盤、吸籌、出貨
    均線戰法、黃金分割
    經典K線、趨勢形態
    牛股黑馬、王子理論
    漲停、周線、月線
    止盈、止損、支撐、壓力
    案例、波浪、口訣、選股
    分時、盤口、補倉、解套
  4. 技術指標
    DDX
    DDY
    DDZ
    MACD
    KDJ
    CCI
    OBV
    BOLL
    RSI
    VOL
    CR
    WR
3d彩票软件小强