»查看更多分類股票軟件

超贊的極品指標 通達信主圖指標 源碼 貼圖

發布時間:2019-06-16 08:34:00  點擊:

超贊的極品指標 通達信主圖指標 源碼 貼圖

超贊的極品指標 通達信主圖指標 源碼 貼圖


{超贊的極品}
Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORLIRED;
DRAWTEXT_FIX(ISLASTBAR,0,0.03,0,EXTERNSTR(0,3)),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR,0,0.06,0,EXTERNSTR(0,6)),COLORLIBLUE;
DRAWTEXT_FIX(ISLASTBAR,0,0.09,0,EXTERNSTR(0,12)),COLORLIGREEN;{老王}
DRAWTEXT_FIX(ISLASTBAR,0,0.15,0,FGBLOCK),COLORLIMAGENTA;
DRAWTEXT_FIX(ISLASTBAR,0,0.12,0,EXTERNSTR(0,1)),COLORYELLOW;{融勝}
主力成本線:EMA(COST(9),250),COLORBROWN,DOTLINE;
{牛馬線買點公式升級版 www.jmyzdc.tw}
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
牛線:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,COLORRED;
馬線:MA(牛線,8),COLORWHITE;
DRAWICON( FILTER(CROSS(牛線,馬線),20),馬線-0.002 ,1);
DRAWTEXT(CROSS(牛線,馬線),LOW*0.984,'買'),COLORRED,LINETHICK2;
止損價:H*0.95,LINETHICK0.5,COLORRED;
莊家:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,COLORRED;
IF(莊家>=REF(莊家,1),莊家,DRAWNULL),COLORRED,LINETHICK4;
IF(莊家<=REF(莊家,1),莊家,DRAWNULL),COLORGREEN,LINETHICK2;
DRAWBAND(牛線,RGB(255,87,22),馬線,RGB(0,30,255));
MA60:MA(CLOSE,60),COLORGRAY;
N1:=10;
TK:=CONST(HHVBARS(V,10)),COLOR0000FF,LINETHICK1;
量能平臺:IF(CURRBARSCOUNT<=N1+3,CONST(IF(TK=0,C,REF(C,TK))),DRAWNULL),COLORGRAY,LINETHICK1;
NOTEXT_新量能點:IF(CURRBARSCOUNT=TK+1,量能平臺,DRAWNULL),CIRCLEDOT,COLORFFFFFF,LINETHICK9;
DRAWTEXT(ISLASTBAR,量能平臺,'量能平臺'),COLORGRAY;
{穩漲}
紅軌道:=MA(MA(CLOSE,3),1),LINETHICK1,COLORYELLOW;
軌道:MA(MA(CLOSE,3),3),COLOR32CD32,LINETHICK2;
NOTEXT_升:IF(紅軌道>=軌道,軌道,DRAWNULL),COLORMAGENTA,LINETHICK2;
機構:(L2_VOL(0,0) - L2_VOL(0,1))*10000/FINANCE(7),NODRAW,COLORRED;
大戶:(L2_VOL(1,0) - L2_VOL(1,1))*10000/FINANCE(7),NODRAW,COLORMAGENTA;
主力:機構+大戶,NODRAW,COLORYELLOW;
STICKLINE(主力>0,O,C,1.5,1),COLORRED;
STICKLINE(主力<0,O,C,1.5,1),COLORCYAN;
STICKLINE(大戶>0,O,C,1,0),COLORMAGENTA;
STICKLINE(大戶<0,O,C,1,0),COLORGREEN;
STICKLINE(機構>0 AND 大戶>0,O,(O+C)/2,1,0),COLORRED;
STICKLINE(機構<0 AND 大戶>0,C,(O+C)/2,1,0),COLORCYAN;
STICKLINE(機構>0 AND 大戶<0,O,(O+C)/2,1,0)COLORMAGENTA;
STICKLINE(機構<0 AND 大戶<0,C,O,1,0)COLORLICYAN;
累計:=SUM(主力,30),COLORMAGENTA;
均值:=EMA(累計,MIN(10,30)),COLORWHITE;
{紅}
STICKLINE(CROSS(累計,均值),H,L,0,0),COLORRED,LINETHICK1;
STICKLINE(CROSS(累計,均值),CLOSE,OPEN,1.4,0),COLOR000088;
STICKLINE(CROSS(累計,均值),CLOSE,OPEN,1,0),COLOR0000BB;
STICKLINE(CROSS(累計,均值),CLOSE,OPEN,0.6,0),COLOR0000DD;
STICKLINE(CROSS(累計,均值),CLOSE,OPEN,0,0),COLOR0000FF;
{藍}
STICKLINE(CROSS(均值,累計),H,L,0,0),COLORFF8800,LINETHICK1;
STICKLINE(CROSS(均值,累計),CLOSE,OPEN,1.4,0),COLORBB4400;
STICKLINE(CROSS(均值,累計),CLOSE,OPEN,1,0),COLORCC5500;
STICKLINE(CROSS(均值,累計),CLOSE,OPEN,0.6,0),COLORDD6600;
STICKLINE(CROSS(均值,累計),CLOSE,OPEN,0,0),COLOREE7700;
{高低點定位}
G0:=(XMA(XMA(H,30),30)-XMA(XMA(L,30),30))+XMA(XMA(H,30),30);
D0:=XMA(XMA(L,30),30)-(XMA(XMA(H,30),30)-XMA(XMA(L,30),30));
G01:=(XMA(XMA(H,30),30)-XMA(XMA(L,30),30))*0.5+XMA(XMA(H,30),30);
D01:=XMA(XMA(L,30),30)-(XMA(XMA(H,30),30)-XMA(XMA(L,30),30))*0.5;
GO0:=(XMA(XMA(H,60),60)-XMA(XMA(L,60),60))*3+XMA(XMA(H,60),60);
DO0:=XMA(XMA(L,60),60)-(XMA(XMA(H,60),60)-XMA(XMA(L,60),60))*3;
STICKLINE(CURRBARSCOUNT=1,G0,G0,100,5),COLORGREEN;
STICKLINE(CURRBARSCOUNT=1,D0,D0,100,5),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=1,GO0,GO0,100,5),COLORLIBLUE;
STICKLINE(CURRBARSCOUNT=1,DO0,DO0,100,5),COLORRED;
DRAWTEXT(ISLASTBAR,G0,'賣'),COLORGREEN;
DRAWTEXT(ISLASTBAR,D0,'買'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,GO0,'頂'),COLORLIBLUE;
DRAWTEXT(ISLASTBAR,DO0,'底'),COLORRED;
{五線順上的拐點定位線,有未來函數}
局部低點預選A:=BACKSET(LLV(L,5)<REF(LLV(L,4),1),4);
局部低點預選B:=BACKSET(局部低點預選A=0 AND REF(局部低點預選A,1)=1,2);
局部低點預選C:=IF(局部低點預選B=1 AND REF(局部低點預選B,1)=0,-1,0);
局部高點預選A:=BACKSET(HHV(H,5)>REF(HHV(H,4),1),4);
局部高點預選B:=BACKSET(局部高點預選A=0 AND REF(局部高點預選A,1)=1,2);
局部高點預選C:=IF(局部高點預選B=1 AND REF(局部高點預選B,1)=0,1,0);
缺口判斷:=IF(L>REF(H,1),1,IF(H<REF(L,1),-1,0));
距前高天:=BARSLAST(局部高點預選C=1);
距前低天:=BARSLAST(局部低點預選C=-1);
小值周期:=LOWRANGE(L);
大值周期:=TOPRANGE(H);
低保留AA:=IF(局部低點預選C=-1 AND REF(距前高天,1)>REF(距前低天,1) AND LLV(L,距前高天+1)<REF(LLV(L,距前高天+1),1),-1,0);
低保留AB:=IF(局部低點預選C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND (距前高天>=4 OR LLV(缺口判斷,距前高天)=-1 OR LLV(L,距前低天+2)<REF(LLV(L,距前低天+1),1)),-1,0);
低保留S:=IF((低保留AA=-1 OR 低保留AB=-1) AND L<REF(H,距前高天+1),-1,0);
預判:=IF((距前低天<4 AND HHV(缺口判斷,距前低天)!=1) OR REF(低保留S,距前低天)=0,1,0);
判斷:=IF(局部高點預選C=1 AND REF(距前低天,1)<=REF(距前高天,1) AND 預判=1 AND 大值周期>REF(小值周期,距前低天+1) AND 大值周期>REF(小值周期,距前低天) AND 大值周期>REF(大值周期,距前高天),1,0);
高保留A:=IF(局部高點預選C=1 AND REF(距前低天,1)>REF(距前高天,1) AND HHV(H,距前低天+1)>REF(HHV(H,距前低天+1),1),1,0);
高保留B:=IF(局部高點預選C=1 AND REF(距前低天,1)<=REF(距前高天,1) AND REF(低保留S,距前低天)=-1 AND (距前低天>=4 OR HHV(缺口判斷,距前低天)=1),1,0);
高保留:=IF((高保留A=1 OR 高保留B=1 OR 判斷=1) AND H>REF(L,距前低天+1),1,0);
預判A:=IF((距前高天<4 AND HHV(缺口判斷,距前高天)!=1) OR REF(高保留,距前高天)=0,1,0);
判斷A:=IF(局部低點預選C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND 預判A=1 AND 小值周期>REF(大值周期,距前高天+1) AND 小值周期>REF(大值周期,距前高天) AND 小值周期>REF(小值周期,距前低天),-1,0);
低保留A:=IF(局部低點預選C=-1 AND REF(距前高天,1)>REF(距前低天,1) AND LLV(L,距前高天+1)<REF(LLV(L,距前高天+1),1),-1,0);
低保留B:=IF(局部低點預選C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND (距前高天>=4 OR LLV(缺口判斷,距前高天)=-1 OR 判斷A=-1),-1,0);
低保留:=IF((低保留A=-1 OR 低保留B=-1) AND L<REF(H,距前高天+1),-1,0);
距前高天A:=BARSLAST(高保留=1);
距前低天A:=BARSLAST(低保留=-1);
預判X:=IF((距前低天A<4 AND HHV(缺口判斷,距前低天A)!=1) OR REF(低保留,距前低天A)=0,1,0);
判斷X:=IF(局部高點預選C=1 AND REF(距前低天A,1)<=REF(距前高天A,1) AND 預判X=1 AND 大值周期>REF(小值周期,距前低天A+1) AND 大值周期>REF(小值周期,距前低天A) AND 大值周期>REF(大值周期,距前高天A),1,0);
高保留XA:=IF(局部高點預選C=1 AND REF(距前低天A,1)>REF(距前高天A,1) AND HHV(H,距前低天A+1)>REF(HHV(H,距前低天A+1),1),1,0);
高保留XB:=IF(局部高點預選C=1 AND REF(距前低天A,1)<=REF(距前高天A,1) AND REF(低保留,距前低天A)=-1 AND (距前低天A>=4 OR HHV(缺口判斷,距前低天A)=1),1,0);
高保留X:=IF((高保留XA=1 OR 高保留XB=1 OR 判斷X=1) AND H>REF(L,距前低天A+1),1,0);
預判XA:=IF((距前高天A<4 AND HHV(缺口判斷,距前高天A)!=1) OR REF(高保留XA,距前高天A)=0,1,0);
判斷XA:=IF(局部低點預選C=-1 AND REF(距前高天A,1)<=REF(距前低天A,1) AND 預判XA=1 AND 小值周期>REF(大值周期,距前高天A+1) AND 小值周期>REF(大值周期,距前高天A) AND 小值周期>REF(小值周期,距前低天A),-1,0);
低保留XA:=IF(局部低點預選C=-1 AND REF(距前高天A,1)>REF(距前低天A,1) AND LLV(L,距前高天A+1)<REF(LLV(L,距前高天A+1),1),-1,0);
低保留XB:=IF(局部低點預選C=-1 AND REF(距前高天A,1)<=REF(距前低天A,1) AND (距前高天A>=4 OR LLV(缺口判斷,距前高天A)=-1 OR 判斷XA=-1),-1,0);
低保留X:=IF((低保留XA=-1 OR 低保留XB=-1) AND L<REF(H,距前高天A+1),-1,0);
距前高天YA:=BARSLAST(高保留X=1);
距前低天YA:=BARSLAST(低保留X=-1);
預判YX:=IF((距前低天YA<4 AND HHV(缺口判斷,距前低天YA)!=1) OR REF(低保留X,距前低天YA)=0,1,0);
判斷YX:=IF(局部高點預選C=1 AND REF(距前低天YA,1)<=REF(距前高天YA,1) AND 預判YX=1 AND 大值周期>REF(小值周期,距前低天YA+1) AND 大值周期>REF(小值周期,距前低天YA) AND 大值周期>REF(大值周期,距前高天YA),1,0);
高保留YXA:=IF(局部高點預選C=1 AND REF(距前低天YA,1)>REF(距前高天YA,1) AND HHV(H,距前低天YA+1)>REF(HHV(H,距前低天YA+1),1),1,0);
高保留YXB:=IF(局部高點預選C=1 AND REF(距前低天YA,1)<=REF(距前高天YA,1) AND REF(低保留X,距前低天YA)=-1 AND (距前低天YA>=4 OR HHV(缺口判斷,距前低天YA)=1),1,0);
高保留YX:=IF((高保留YXA=1 OR 高保留YXB=1 OR 判斷YX=1) AND H>REF(L,距前低天YA+1),1,0);
預判YXA:=IF((距前高天YA<4 AND HHV(缺口判斷,距前高天YA)!=1) OR REF(高保留YXA,距前高天YA)=0,1,0);
判斷YXA:=IF(局部低點預選C=-1 AND REF(距前高天YA,1)<=REF(距前低天YA,1) AND 預判YXA=1 AND 小值周期>REF(大值周期,距前高天YA+1) AND 小值周期>REF(大值周期,距前高天YA) AND 小值周期>REF(小值周期,距前低天YA),-1,0);
低保留YXA:=IF(局部低點預選C=-1 AND REF(距前高天YA,1)>REF(距前低天YA,1) AND LLV(L,距前高天YA+1)<REF(LLV(L,距前高天YA+1),1),-1,0);
低保留YXB:=IF(局部低點預選C=-1 AND REF(距前高天YA,1)<=REF(距前低天YA,1) AND (距前高天YA>=4 OR LLV(缺口判斷,距前高天YA)=-1 OR 判斷YXA=-1),-1,0);
低保留YX:=IF((低保留YXA=-1 OR 低保留YXB=-1) AND L<REF(H,距前高天YA+1),-1,0);
AAAD:=IF(高保留YX=1 AND 低保留YX=-1 AND H>REF(H,REF(距前高天YA,1)+2),1,IF(高保留YX=1 AND 低保留YX=-1 AND L<REF(L,REF(距前低天YA,1)+2),-1,0));
極點保留:=IF(AAAD=0,高保留YX+低保留YX,AAAD);
局部極點:IF(極點保留=-1,L,IF(極點保留=1,H,DRAWNULL)),CIRCLEDOT,COLORYELLOW;
DRAWLINE(極點保留=-1,局部極點,極點保留=1,局部極點,0)COLORLIRED,LINETHICK1;
DRAWLINE(極點保留=1,局部極點,極點保留=-1,局部極點,0)COLORLICYAN,LINETHICK1;
DD1:=BARSLAST(ABS(極點保留)!=1);
DRAWTEXT(極點保留=1,局部極點,'賣'),COLORLIBLUE;
DRAWTEXT(極點保留=-1,局部極點,'買'),COLORRED;
{一絕}
Q_1:=C-REF(C,1);
Q_2:=100*EMA(EMA(Q_1,6),6)/EMA(EMA(ABS(Q_1),6),6);
Q_3:=CROSS(EMA(C,19),EMA(C,7));
Q_4:=CROSS(EMA(C,7),EMA(C,19));
ZD1:=L=LLV(L,BARSLAST(Q_3)+1);
ZD2:=LLV(L,BARSLAST(Q_3)+1);
ZD3:=H=HHV(H,BARSLAST(Q_4)+1);
ZD4:=HHV(H,BARSLAST(Q_4)+1);
Q_A:=DRAWLINE(ZD1,ZD2,ZD3,ZD4,0);
U1:=H=HHV(H,BARSLAST(Q_4)+1);
U2:=HHV(H,BARSLAST(Q_4)+1);
U3:=L=LLV(L,BARSLAST(Q_3)+1);
U4:=LLV(L,BARSLAST(Q_3)+1);
Q_B:=DRAWLINE(U1,U2,U3,U4,0);
TJ:=IF(Q_B<REF(Q_B,1) AND Q_B=Q_A,1,0);
BB:=REF(TJ,1)=0 AND TJ>=1 ;
DRAWICON(BB,L*0.998,34);
SS:=REF(Q_A<REF(Q_A,1) AND Q_B=Q_A,1)=0 AND TJ<1;
DRAWICON(SS,H*1.002,35);
{私募公式}
AAE:= WINNER(CLOSE+CLOSE*15/100)*100;
BBE:= WINNER(CLOSE+CLOSE*0/100)*100;
CCE:= AAE-BBE;
DDE:= (WINNER(CLOSE-CLOSE*0.1/100)-WINNER(CLOSE-CLOSE*15/100))*100;
EEE:= CCE<3 AND DDE<0.5 AND OPEN>LOW;
AE1:= DYNAINFO(6);
AE2:= IF(LOW>AE1,0,IF(HIGH<AE1,1,(AE1-LOW+0.01)/(HIGH-LOW+0.01)));
AE3:= VOL/WINNER(LOW);
AE4:= REF(HHV(CLOSE,120),1);
AE5:= REF(LLV(CLOSE,120),1);
AE6:= 100*(CLOSE-AE5)/(AE4-AE5);
AE7:= AE2>0 OR AE2=1;
AE8:= AE7 AND AE3/REF(AE3,3)>=3 AND AE6<80;
AE9:= REF(AE8,1) OR REF(AE8,2) OR REF(AE8,3) OR REF(AE8,4);
AE10:= AE8 AND AE9;
AE11:= IF(FILTER(AE8,3),5,0);
AE12:= FILTER(IF(FILTER(AE10,3) OR EEE,10,0),3);
DRAWICON(AE12,L-0.0018,13);
{新趨勢線};
AX1:=REF(H,8)=HHV(H,2*8+1);
BX1:=FILTER(AX1,8);
CX1:=BACKSET(BX1,8+1);
DX1:=FILTER(CX1,8);{高點}
RX1:=BACKSET(ISLASTBAR,BARSLAST(DX1)+1);
SX1:=RX1>REF(RX1,1);
DRAWLINE(DX1,H,SX1,H,1),COLORBLUE,DOTLINE;
AX2:=REF(L,8)=LLV(L,2*8+1);
BX2:=FILTER(AX2,8);
CX2:=BACKSET(BX2,8+1);
DX2:=FILTER(CX2,8);{低點}
TX1:=BACKSET(ISLASTBAR,BARSLAST(DX2)+1);
UX1:=TX1>REF(TX1,1);
DRAWLINE(DX2,L,UX1,L,1),COLORLIMAGENTA,DOTLINE;
M:=INTPART(3*8/5);
AV2:=REF(H,M)=HHV(H,2*M+1);
BV2:=FILTER(AV2,M);
CV2:=BACKSET(BV2,M+1);
DV2:=FILTER(CV2,M);{高點}
RV2:=BACKSET(ISLASTBAR,BARSLAST(DV2)+1);
SV2:=RV2>REF(RV2,1);
DRAWLINE(DV2,H,SV2,H,1),COLORLIBLUE,DOTLINE;
A22:=REF(L,M)=LLV(L,2*M+1);
B22:=FILTER(A22,M);
C22:=BACKSET(B22,M+1);
D22:=FILTER(C22,M);{低點}
T112:=BACKSET(ISLASTBAR,BARSLAST(D22)+1); U112:=T112>REF(T112,1);
DRAWLINE(D22,L,U112,L,1),COLORMAGENTA,DOTLINE;
{伏擊漲停}
T1:=MA(C,21)>REF(MA(C,21),1);
T2:=EXIST(C>REF(C,1)*1.093,21);
T3:=C<O AND C<REF(C,1) AND EVERY(MA(C,5)<REF(MA(C,5),1),3);
T5:=EVERY(V<REF(V,1),2) AND EVERY(V<MA(V,5),2);
T6:=MA(C,5)>MA(C,21);
DRAWTEXT(T1 AND T2 AND T3 AND T5 AND T6,L,'--伏擊漲停');
{紅底綠頂}
低:=REF(LLV(L,150),3);
近期底:=REFDATE(低,DATE);
最底:=REFDATE(近期底,DATE);
入:=最底=L AND ((C+L)<(O+C) OR (O+L)<(C+O));
STICKLINE(入,O,(C+O)/2,3,0),COLORRED;
STICKLINE(入,H,L,0.2,0),COLORRED;
DRAWTEXT(入,L*1.0021,'-紅底'),COLORLIMAGENTA;
高:=REF(HHV(H,150),3);
近期頂:=REFDATE(高,DATE);
最頂:=REFDATE(近期頂,DATE),NODRAW;
出:=最頂=H AND ((C-L)<(O-C) OR (O-L)<(C-O)),NODRAW;
STICKLINE(出,O,(C+O)/2,3,0),COLORBLUE;
STICKLINE(出,H,L,0.2,0),COLORBLUE;
DRAWTEXT(出,H*0.998,'--藍頂'),COLORGREEN;
A2:=REF(MA(C,20),1);J1:=(MA(C,20)-A2)/A2*100;MJ1:=MA(J1,3);
乖離2:=(MA(C,20)-MA(C,30))/MA(C,30)*100;
VAC1:=IF(BETWEEN(乖離2,-2,5),2,0);
XL1:=((LLV(LOW,3) = LLV(LOW,60)) AND ((CLOSE / REF(CLOSE,1)) >= 1.04));
XL2:=(((CLOSE - EMA(CLOSE,21)) / EMA(CLOSE,21)) * 100);
XL3:=CROSS(XL2,(0 - 20));
DRAWTEXT(FILTER(((XL1 > 0) AND LOW),5),(LOW - 0.0014),'●買點');
DRAWTEXT((XL3 > 0),(LOW - 0.0011),'●絕對底部')COLORYELLOW;
X6:=REF(CLOSE,1);
X7:=((SMA(MAX((CLOSE - X6),0),7,1) / SMA(ABS((CLOSE - X6)),7,1)) * 100);
X8:=CROSS(79,X7);
X9:=FILTER(X8,4);
DRAWTEXT(X9,(HIGH * 0.9989),'-●出貨'),COLORGREEN;
{金牛啟動}
年:=MA(CLOSE,240);
漲幅%:=(C-REF(C,1))/REF(C,1)*100;
RSVV:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
VARB2:=(RSVV/2+22)*1;
量:=EMA(VOL,13);
資金:=EMA(AMOUNT,13);
過濾:=((資金 /量) / 100);
提純:=(((CLOSE -過濾) / 過濾) * 100);
黃金:=((提純 < (0)) AND ZXNH);
買:=IF(黃金 AND RSVV<VARB2-2,180,0) AND 漲幅%>0 AND C<年;
DRAWTEXT(買>0,L-0.0013,'-牛'),COLORFFFFFF;
DRAWTEXT(買>0,L-0.0018,'▲'),COLORFF00FF;
AA05:=MA(C,5),COLOR0099CC;
五日乖離率:=(C-AA05)/AA05*100;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
加速度5:EMA((速度5-REF(速度5,1)),3),NODRAW;
AA10:=MA(C,10);
AA20:=MA(C,20);BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;
AA30:=MA(C,30);
三拾日乖離率:=(C-AA30)/AA30*100;
VAR11:=(AA20-AA30)>REF((AA20-AA30),1)
AND AA20>REF(AA20,1) AND AA30>REF(AA30,1);
VAR22:=(AA30-AA20)<REF((AA30-AA20),1) AND AA20<REF(AA20,1) AND
AA30<REF(AA30,1);
BB30:=ATAN((AA30/REF(AA30,1)-1)*100)*180/3.1416;
強勢狙擊:=FILTER(BB30>30 AND BB10>45 AND
CROSS(BB05,60),10);
加倉:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND
AA05>REF(AA05,1) AND 三拾日乖離率>REF(三拾日乖離率,1) AND
AA10>REF(AA10,1)
AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;
清倉:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>AA30 OR O>AA30) AND
AA05<REF(AA05,1) AND 三拾日乖離率<REF(三拾日乖離率,1) AND
AA10<REF(AA10,1),10);
DRAWICON(加倉 ,LOW*0.997,21);
DRAWICON(清倉 ,HIGH*1.005,12);
DRAWICON(強勢狙擊 ,LOW*0.997,11);
{俊俊出擊-選股}
S1:=MA((2*C+H+L)/4,5);
S2:=S1*(200-102)/100;
S3:=(1-7/100)*DMA(C,ABS((2*C+H+L)/4-MA(C,20))/MA(C,20));
S4:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
S5:=3*SMA(S4,3,1)-2*SMA(SMA(S4,3,1),3,1);
S6:=((H+L+C)/3-MA((H+L+C)/3,14))/(0.015*AVEDEV((H+L+C)/3,14));
DRAWTEXT(S2<S3&&S5>REF(S5,1)&&REF(S5,1)<REF(S5,2)&&S6<-100&&S6>REF(S6,1),L-0.0018,'俊'),COLORYELLOW;
{洗盤殺入線源碼:}{www.jmyzdc.tw}
T11:=CONST(LLVBARS(LOW,10));
T11HIGH:=CONST(REF(HIGH,T11));
CC1:=CONST(CURRBARSCOUNT);
T22:=CONST(BARSLAST(CURRBARSCOUNT>CC1+T11 AND H>T11HIGH));
T22HIGH:=CONST(REF(HIGH,T22));
T33:=CONST(BARSLAST(CURRBARSCOUNT>CC1+T22 AND HIGH>T22HIGH));
T33HIGH:=CONST(REF(HIGH,T33));
{C>=T33HIGH AND REF(C,1)<T33HIGH AND DYNAINFO(17)>2;}
N:=10;
T1K:=CONST(LLVBARS(LOW,N));
T1HIGH:=CONST(REF(HIGH,T1K));
CC:=CONST(CURRBARSCOUNT);
T2K:=CONST(BARSLAST((CURRBARSCOUNT >(CC+T1K)) AND (HIGH>T1HIGH)));
T2HIGH:=CONST(REF(HIGH,T2K));
T3K:=CONST(BARSLAST((CURRBARSCOUNT >(CC+T2K)) AND (HIGH>T2HIGH)));
T3HIGH:=CONST(REF(HIGH,T3K));
洗盤殺入線:DRAWLINE(CURRBARSCOUNT=10+1,T3HIGH,ISLASTBAR, T3HIGH,1),LINETHICK1,COLORLIRED;
DRAWTEXT(ISLASTBAR, T3HIGH,'殺入線')LINETHICK1,COLORLIRED;
AQ1:=REF(V,1);AQ2:=DVOL;AQ3:=AQ2/AQ1;
LNX:=AQ3-REF(AQ3,1);
E1:=REF(C,1);E2:=DCLOSE;E3:=(E2-E1)/E1*100;
QMX:=E3-REF(E3,1);
XG:=CROSS(LNX,500) AND CROSS(QMX,10);
DRAWTEXT(XG=1,L*0.995,'--鉆石'),COLORFFCC88;
DRAWICON(XG=1,L*0.993,25);
{有莊控盤}
VAW1:=EMA(EMA(CLOSE,13),13);
控盤:=(VAW1-REF(VAW1,1))/REF(VAW1,1)*1000;
無莊控盤:=控盤<0;
有莊控盤:=控盤>REF(控盤,1) AND 控盤>0;
{分時價格原碼}
JJ:=DYNAINFO(11);
{波段買賣原碼}
P:=21;S:=8;M1:=3;
財:=(EMA(CLOSE,S)-EMA(CLOSE,P))*50;
神:=EMA(財,M1);
{股價與均線偏離買賣條件}
BTJ1:=(C-JJ)/JJ<-0.03;
BTJ11:=(C-JJ)/JJ<-0.03;
BTJ12:=LAST(JJ>=REF(JJ,1),5,1) AND (C-JJ)/JJ<0.005;
STJ1:=(C-JJ)/JJ>0.005;
{控盤買賣條件}
STJ01:=控盤<REF(控盤,1) AND 控盤>0.5;
STJ02:=控盤>0;
BTJ2:=控盤>REF(控盤,1) AND 控盤<-0.2;
BTJ22:=控盤>REF(控盤,1) AND 控盤<0 ;
{波段買賣條件}
BTJ3:=CROSS(財,神) AND 財<-0.3;
BTJ32:=CROSS(財,神) AND 財<-0.1;
STJ31:=CROSS(神,財);
STJ32:=CROSS(神,財) AND 財>1.618;
{以下為信號};
BTJ81:=FILTER(BTJ1 AND BTJ2 AND BTJ3,13);
BTJ811:=FILTER(BTJ11 AND BTJ2 AND BTJ3,13);
BTJ82:=FILTER(BTJ12 AND BTJ22 AND BTJ32,13);
STJ81:=FILTER(STJ1 AND STJ01 AND STJ31,13);
STJ82:=FILTER(STJ02 AND STJ32 ,13);
STJ83:=STJ81 AND STJ82;

DRAWTEXT(STJ83,H*1.002,'↓莊出'),COLORGREEN;
DRAWICON(STJ83,H+0.003,24);
莊:= BTJ11 AND BTJ2 AND BTJ3;
有莊:=FILTER(莊,30);
DRAWTEXT(有莊,L-0.0011,'↖莊進'),COLORYELLOW;
DRAWICON(有莊,L*0.999,23);
{牛熊軌道上抓啟爆點 適合抓爆漲股}
AHC1:=CLOSE*VOL;
AHC22:=EMA((EXPMA(AHC1,27)/EXPMA(VOL,27)+EXPMA(AHC1,54)/EXPMA(VOL,54)+EXPMA(AHC1,108)/EXPMA(VOL,108)+EXPMA(AHC1,316)/EXPMA(VOL,316))/4,34);
上軌:=1.06*AHC22;
下軌:=AHC22*0.94;
ZT:=REF(C,1)*1.1-C<0.01 AND H=C;
啟爆:=CROSS(C,上軌) OR CROSS(C,下軌) AND ZT;
DRAWTEXT(啟爆,L,'↖啟爆'),COLORCYAN;
{STYLE:抄底鉆石王--可以用于選股預警,也可以放到附圖}
YY:=(REF(H,4)-REF(L,1))/C*100>10;{4天前的最高到昨天最低跌幅為10個點}
YY1:=(REF(L,1)-L)/C*100>=0;{昨天的最低價跟今天最低價相平或收下影線}
YY2:=REF(C<O,1) AND C>O;{昨天收陰,今天收陽線}
YY3:= CLOSE>REF(CLOSE,1)*1.03 ;{股價3個點預警}
YY4:=(H-C)/C*100<1.5;{上影線少于1.5個點}
YY5:=V<=LLV(V,5) OR V>=HHV(V,5);{成交量是五天最低或五天最高}
DRAWICON(YY AND YY1 AND YY2 AND YY3 AND YY4 AND YY5,L*0.988,26);{滿足所有條件};
DRAWTEXT(YY AND YY1 AND YY2 AND YY3 AND YY4 AND YY5,L*0.988,'--鉆石王'),COLORRED;


 
超贊的極品指標 通達信主圖指標 源碼 貼圖
打開微信掃一掃,一鍵復制指標源碼,
輕松快捷粘貼至手機通達信APP中。
0

本站提示:股市有風險,入市請慎重,資料由股票下載網整理收集

找不到你要的公式?給我們建議

  1. 股票軟件
    股票分析軟件
    股票交易軟件
    股票行情軟件
    指標股票池
    手機炒股軟件
    書籍教程
    數據軟件
    工具補丁
    大智慧
    通達信
    飛狐
    東方財富通
    操盤手
    指南針
    分析家
    同花順
    錢龍
    證券之星
    券商股票軟件
    特色行情軟件
    迷你行情軟件
    金融界軟件
    美股外盤軟件
    大智慧股票池
    通達信股票池
    大智慧L2公式
    通達信公式
    飛狐公式
    同花順公式
    股票書藉
    視頻教程
    金融書籍
    其他書籍
    資訊評測軟件
    資金分析軟件
    數據接口軟件
    江恩波浪軟件
    數據下載軟件
    軟件數據投資
    選股軟件
    登錄補丁
    其他應用
    股軟教程
  2. 股票公式
    通達信公式
    大智慧公式
    飛狐公式
    同花順公式
    東方財富通公式
    金字塔指標公式
    文華指標公式
    MT4指標
    博易大師指標
    公式教程答疑
  3. 炒股知識
    短線技巧
    軟件公式
    炒股視頻
    股票入門
    股市實戰信息交流
    炒股技巧
    股票基礎知識
    技術分析
    炒股一招先
    基本面分析
    股票視頻教程
    股票買賣技巧
    k線圖分析
    胡立陽教你買股票
    短線炒股技巧
    天狼之眼
    波浪理論技術講解
    股市贏家楊百萬
    股票理論、T0纏論、知識
    經典指標、交易系統
    成交量能、籌碼分析
    買賣信號、技術分析
    挖坑、冼盤、吸籌、出貨
    均線戰法、黃金分割
    經典K線、趨勢形態
    牛股黑馬、王子理論
    漲停、周線、月線
    止盈、止損、支撐、壓力
    案例、波浪、口訣、選股
    分時、盤口、補倉、解套
  4. 技術指標
    DDX
    DDY
    DDZ
    MACD
    KDJ
    CCI
    OBV
    BOLL
    RSI
    VOL
    CR
    WR
3d彩票软件小强